Issues with Broadcast API
Incident Report for TokBox
Postmortem

Timeline

On Friday, August 24, 2018 around 12:00 pm PST, we begin detecting errors in communication between broadcast services.

At 12:48 PM PST, we received our first report from a customer that the broadcast update layout API calls were not working.

At 17:01 PDT, we resolved the issue.

Root-Cause Analysis

In rolling out a new version of our API servers we ran into incompatibilities between the different versions of our API servers.

Remediation

We are exploring using an improved deployment strategy that will allow us to do more testing of the deployment to ensure that all components are working correctly together before enabling a full deployment.

Posted 3 months ago. Aug 28, 2018 - 11:25 PDT

Resolved
This incident has been resolved.
Posted 3 months ago. Aug 24, 2018 - 17:01 PDT
Investigating
We should note we are identifying an issue reported by a customer who is experiencing issues with the Broadcast API.
Posted 3 months ago. Aug 24, 2018 - 13:43 PDT
This incident affected: Enterprise (Enterprise Broadcast) and Standard (Standard Broadcast).