Issues with Diagnostic Tool Inspector
Incident Report for TokBox
Postmortem

What happened

On October 15th 2018 at 6:14 PT until October 18th 12:34 PT, some customers were unable to authenticate to the Tokbox diagnostic tool ‘Inspector’. Deleting Tokbox cookies forced users to re-authenticate which resolved the issue temporarily.

Cause

A change to the OpenTok single sign-on taking place as part of an application enhancement, uncovered a problem with the token expiry times logic of the tool. This prevented users from authenticating under certain circumstances. The enhancement was rolled back and a patch was deployed to resolve the problem on October 18th, at 12:34pm PT.

Corrective Actions

We are updating Inspector authentication to make it consistent with other TokBox applications. This will simplify our process for testing future changes to Single SignOn. The update is planned to happen on or before October 30th 2018.

Posted 8 months ago. Oct 23, 2018 - 13:37 PDT

Resolved
This incident is now resolved.

Please contact support@tokbox.com if you have questions.
Posted 8 months ago. Oct 18, 2018 - 14:05 PDT
Identified
We have identified the problem and we are working on a solution.

In the meantime if you are experiencing this issue, deleting the tokbox.com cookies will work as a temporary work around. This will force you to re-authenticate.

Please contact support@tokbox.com if you have any questions.
Posted 8 months ago. Oct 18, 2018 - 11:46 PDT
Investigating
We are currently experiencing intermittent issues with our diagnostic tool Inspector.

We will update this announcement as soon as there is more information and/or the issue is resolved.
Posted 8 months ago. Oct 17, 2018 - 10:21 PDT
This incident affected: Tools.